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BÀI 5 NGÀY 29.8.2010 ÚT B N˃H SOʛN THEO THʡY TUʟN 

CÓ TH  ̔ KHI XEM BÀI 4 B ʛN CHʆA Cč KHĆI NIMˁ RÕ RÀNG V  ̒ LʧP TRÌNH 

TRONG VISUAL BASIC 6.0 NHʆNG KHI THAM KHʝO VÀ THξC TʧP BÀI NÀY B ʛN 

DʡN DʡN HI U̔ BI T́ KHÁI NI Mˁ VÀ DI Nˁ MʛO CδA CÁCH LʧP TRÌNH VÀ CÁCH 

TH  ̔HI Nˁ,CÔNG DβNG CδA NÓ. HI Nˁ NAY TRÊN MʛNG CÓ RʟT NHI U̒ TÀI LI Uˁ 

V  ̒ VISUAL BASIC 6.0 NHʆNG KHĎNG TH ̔ NêO ņĆP ζNG MΦT CÁCH NHANH 

CHÓNG VÀ HI Uˁ QUʝ ņΝI VΨI NH μNG NGʆΪI M ΨI BʆΨC VÀO LʧP TRÌNH V ΝN 

RʟT KHÓ TI Ṕ THU Vê ņďI HΛI Cč TRČNH ņΦ CAO. ÚT B N˃H MONG RʫNG CÁC 

BÀI VI T́ NÀY S  ̫LÀM THΛA MÃN CÁC BʛN Tξ HΙC VÌ GI ʝN D ,˅D  ʿHI U̔ CδA NÓ. 

BÀI THξC TʧP 1 TʛO 1 CHʆʄNG TRČNH ņʄN GIʝN: CHO XUʟT HI Nˁ TRÊN MÀN 

HÌNH 1 CÂU CHÀO. YÊU CÀU: CLICK VÀO 1 NÚT COMMANDBUTTON S  ̫CHO XUʟT 

HI Nˁ MΦT LΪI CHÀO TRONG TEXTBOX. CLICK VÀO 1 N ÚT COMMANDBUTTON 

KHÁC S  ̫XÓA THÔNG TIN TRONG TEXTBOX. CLICK VÀO 1 NÚT COMMANDBUTTON 

KHÁC S  ̫THOÁT KHΛI CHʆʄNG TRĉNH. 

NHʆ VʧY BʛN S  ̫TʛO: 

 1 FORM Cč TIąU ņ:̒ ñCHʆʄNG TRČNH ņʄN GIʝN ņʡU TIąNò. 

 4 LABEL DĒNG ņ ̔GHI CHĐ TIąU ņ ̒CHO CĆC ņIU̒ KHI N̔. 
 1 TEXTBOX DÙNG  ņ̔  THÔNG BÁO LΪI CHÀO.  

 3 COMMANDBUTTON, TRONG ņč: 1 COMMANDBUTTON DĒNG ņ ̔ XEM 

THÔNG BÁO ï 1 COMMANDBUTTON DĒNG ņ ̔ XÓA THÔNG TIN ï 1 
COMMANDBUTTON DĒNG ņ ̔THOÁT KHΛI CHʆʄNG TRČNH. 

 

FORM CӹN THIԑT Kԑ: 
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I.THI T́ K  ́FORM CHʆʄNG TRČNH 

1.  THI T́ K  ́ 1 FORM CÓ TIÊUņ̒ : ñCHʆʄNG TRČNH ņʄN GIʝN ņʡU 
TIąNò 
 

 NhӸp Shortcut cֳa chҼҺng tr³nh tӴi Desktop > NhӸp Standard EXE > NhӸp Nút Open > 
Hi n֓ ra cֹ a s֡  Project chֵa Form1 d½ng ĽԜ thiԒt kԒ > NhӸp PhӶi lên Form> Ch֙n 

Properties trong Menu hi֓n ra > BӶng xác lԀp thu c֥ tính hi n֓ ra bên PhӶi (Properties-

Form1). 

 Các bӴn có thԜ n i֧ r n֥g hay thu hԌp các Khung ĽԜ ti n֓ thao tác thiԒt kԒ: ToolBox ï 

Project1 ï Form1 - C t֥ Trái bԄng cách ĽԊt con tr֛  lên cӴnh hay góc Ľáy PhӶi c aֳ t nַg 

BӶng, con tr֛  sԐ biԒn thành M iֳ tên 2 ĽӺu, rê thu hԌp hay n֧ i r n֥g BӶng. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 HҼ֧ng dӾn thiԒt lԀp Properties cֳ a FORM1: Ch  ֕ cӺn ch n֙ các Thu֥ c 

tính sau 
 

THU C֤ TÍNH  ħ NGHǪA 

NAME  
X·a th¹ng tin Ľang c·, nhԀp: Baimot. 

Trong VB Ľi֝ tҼn֯g n¨o cȈng c· thuc֥ tính này. 
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BACKCOLOR  

Ch n֙ màu nԚn:Màu vàng nhӴt. 

Click bên PhӶi > NhӸp x  ֡xu n֝g > Ch֙ n Tab Palette > Ch֙ n 

màu. 

CAPTION  
X·a th¹ng tin Ľang c·, nhԀp: CHUONG TRINH DON GIAN 

DAU TIEN. ( Không b  ֛dӸu ). 

WINDOWSTATE  
NhӸp x  ֡xu n֝g, ch֙ n 2-Maximizedd ĽԜ khi chӴy chҼҺng 

trình màn hình sԐ phóng to ra. 

 

 BӴn xác lԀp ( NhԀp vŁn bӶn và tùy ch֙n )  các thu֥ c tính cֳ a Form nhҼ BӶng Ľ« cho nhҼ 
trên. Sau khi xác lԀp thu֥ c tính vào BӶng Properties-Form1, Form sԐ hiԜn th֗  theo các giá 

tr  ֗Ľ« nhԀp . 

 

2.THI T́ K  ́4 LABEL DĒNG ņ ̔GHI CHĐ TIąU ņ ̒CHO CĆC ņIU̒ 

KHI N̔ 

 

A. ThiԒt KԒ LABEL t°n ñNhanmotôô  
 Click ch֙ n 1 ņiԚu KhiԜn (Label) trong ToolBox > Rê tӴo 1 vùng ch֙ n trong Form1 > 

Khi buông chu֥ t ra sԐ hi n֓ ra vùng ch֙ n v aַ tӴo trong Ľó có Label1, 

 HҼ֧ng dӾn thiԒt lԀp Properties cֳ a LABEL t ên ñNhanmotôô : Ch  ֕cӺn 

ch n֙ các Thu֥ c tính sau 
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THU C֤ TÍNH  ħ NGHǪA 

NAME  Tên c aֳ Label. NhԀp: Nhanmot. 

ALIGNMENT  
ņ֗nh dӴng cho thông tin trong Label.  

Ch n֙ 2-Center ĽԜ canh giֻ a. 

BACKCOLOR  

Ch n֙ màu nԚn, click chu t֥ tӴi góc Tr ái > NhӸp x  ֡xu n֝g > 

Ch n֙ Palette > XuӸt hi n֓ BӶng màu, ch֙ n màu Cam, vùng 

ch n֙ Ľ« ĽҼ֯c tô màu Cam. 

CAPTION  X·a th¹ng tin Ľang c·, nhԀp: TextBox thông báo. 

FONT 
NhӸp Ô 3 chӸm bên PhӶi > Ch n֙ Font VNI -Helve-

Condense và Size 12 trong H p֥ ThoӴi  hi n֓ ra. 

 

 BӴn xác lԀp ( NhԀp vŁn bӶn và tùy ch֙n )  các thu֥ c tính cֳ a Label1 nhҼ BӶng Ľ« cho 

nhҼ tr°n. Sau khi x§c lԀp thu֥ c tính vào BӶng Properties-Nhanmot, Form sԐ hiԜn th֗  theo 

các giá tr֗ Ľ« nhԀp . Chú Ý: Khi ch֙ n Font VNI, bӴn nh֧  ch֙ n VNI Windows nԒu xài 

UNIKEY. Khi bӴn nhԀp vŁn bӶn vào trong Caption bӴn sԐ thӸy nó hiԜn th  ֗không Ľúng chֻ  

Vi t֓ có dӸu nhҼng trong Form sԐ hiԜn th  ֗Ľúng chֻ  Vi t֓.BӴn nên xác lԀp Font trҼc֧ khi 

nhԀp vŁn bӶn vào Caption.  

 

 

 

 

 

 

 

 

 

B. ThiԒt KԒ LABEL t°n ñNhanhaiôô  

 

 Click ch֙ n 1 ņiԚu KhiԜn (Label) trong ToolBox > Rê tӴo 1 vùng ch֙ n trong Form1 > 
Khi buông chu֥ t ra sԐ hi n֓ ra vùng ch֙ n v aַ tӴo trong Ľó có Label2, 
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 HҼ֧ng dӾn thiԒt lԀp Properties cֳ a LABEL t ên ñNhanhaiôô : Ch  ֕cӺn 

ch n֙ các Thu֥ c tính sau 

 

THU C֤ TÍNH  ħ NGHǪA 

NAME  Tên c aֳ Label. NhԀp: Nhanhai. 

ALIGNMENT  
ņ֗nh dӴng cho thông tin trong L abel.  

Ch n֙ 2-Center ĽԜ canh giֻ a. 

BACKCOLOR  

Ch n֙ màu nԚn, click chu t֥ tӴi góc Tr ái > NhӸp x  ֡xu n֝g > 

Ch n֙ Palette > XuӸt hi n֓ BӶng màu, ch֙ n màu Cam, vùng 

ch n֙ Ľ« ĽҼ֯c tô màu Cam. 

CAPTION  
X·a th¹ng tin Ľang c·, nhԀp: Click vào nút 

CommandButton ĽԜ xem 

FONT 
NhӸp Ô 3 chӸm bên PhӶi > Ch n֙ Font VNI -Helve-

Condense và Size 12 trong H p֥ ThoӴi  hi n֓ ra. 

 

 BӴn xác lԀp ( NhԀp vŁn bӶn và tùy ch֙n )  các thu֥ c tính cֳ a Label1 nhҼ BӶng Ľ« cho 
nhҼ tr°n. Sau khi x§c lԀp thu֥ c tính vào BӶng Properties-Nhanhai, Form sԐ hiԜn th֗  theo 

các giá tr֗ Ľ« nhԀp . Chú Ý: Khi ch֙ n Font VNI, bӴn nh֧  ch֙ n VNI Windows nԒu xài 

UNIKEY. Khi bӴn nhԀp vŁn bӶn vào trong Caption bӴn sԐ thӸy nó hiԜn th  ֗không Ľúng chֻ  

Vi t֓ có dӸu nhҼng trong Form sԐ hiԜn th  ֗Ľúng chֻ  Vi t֓.BӴn nên xác lԀp Font trҼ֧c khi 

nhԀp vŁn bӶn vào Caption.  
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C. ThiԒt KԒ LABEL t°n ñNhanbaôô  
 

 Click ch֙ n 1 ņiԚu KhiԜn (Label) trong ToolBox > Rê tӴo 1 vùng ch֙ n trong Form1 > 

Khi buông chu֥ t ra sԐ hi n֓ ra vùng ch֙ n v aַ tӴo trong Ľó có Label2, 

 HҼ֧ng dӾn thiԒt lԀp Properties cֳ a LABEL t ên ñNhanbaôô : Ch  ֕cӺn 

ch n֙ các Thu֥ c tính sau 

 

THU C֤ TÍNH  ħ NGHǪA 

NAME  Tên c aֳ Label. NhԀp: Nhanhai. 

ALIGNMENT  
ņ֗nh dӴng cho thông tin trong Label.  

Ch n֙ 2-Center ĽԜ canh giֻ a. 

BACKCOLOR  

Ch n֙ màu nԚn, click chu t֥ tӴi góc Tr ái > NhӸp x  ֡xu n֝g 

> Ch n֙ Palette > XuӸt hi n֓ BӶng màu, ch֙ n màu Cam, 

vùng ch n֙ Ľ« ĽҼ֯c tô màu Cam. 

CAPTION  
X·a th¹ng tin Ľang c·, nhԀp: Click vào nút 

CommandButton ĽԜ xóa 

FONT 
NhӸp Ô 3 chӸm bên PhӶi > Ch n֙ Font VNI -Helve-

Condense và Size 12 trong H p֥ ThoӴi  hi n֓ ra. 

 

 BӴn xác lԀp ( NhԀp vŁn bӶn và tùy ch֙n )  các thu֥ c tính cֳ a Label1 nhҼ BӶng Ľ« cho 
nhҼ tr°n. Sau khi x§c lԀp thu֥ c tính vào BӶng Properties-Nhanba, Form sԐ hiԜn th֗  theo các 

giá tr֗  Ľ« nhԀp . Chú Ý: Khi ch֙ n Font VNI, bӴn nh֧  ch֙ n VNI Windows nԒu xài 

UNIKEY. Khi bӴn nhԀp vŁn bӶn vào trong Caption bӴn sԐ thӸy nó hiԜn th  ֗không Ľúng chֻ  

Vi t֓ có dӸu nhҼng trong Form sԐ hiԜn th  ֗Ľúng chֻ  Vi t֓.BӴn nên xác lԀp Font trҼc֧ khi 

nhԀp vŁn bӶn vào Caption.  
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D. ThiԒt KԒ LABEL t°n ñNhanbonôô  

 
 Click ch֙ n 1 ņiԚu KhiԜn (Label) trong ToolBox > Rê tӴo 1 vùng ch֙ n trong Form1 > 

Khi buông chu֥ t ra sԐ hi n֓ ra vùng ch֙ n v aַ tӴo trong Ľó có Label2, 

 HҼ֧ng dӾn thiԒt lԀp Properties cֳ a LABEL t ên ñNhanbonôô : Ch  ֕cӺn 

ch n֙ các Thu֥ c tính sau 

 

THU C֤ TÍNH  ħ NGHǪA 

NAME  Tên c aֳ Label. NhԀp: Nhanhai. 

ALIGNMENT  
ņ֗nh dӴng cho thông tin trong Label.  

Ch n֙ 2-Center ĽԜ canh giֻ a. 

BACKCOLOR  

Ch n֙ màu nԚn, click chu t֥ tӴi góc Tr ái > NhӸp x  ֡xu n֝g > 

Ch n֙ Palette > XuӸt hi n֓ BӶng màu, ch֙ n màu Cam, vùng 

ch n֙ Ľ« ĽҼ֯c tô màu Cam. 

CAPTION  
X·a th¹ng tin Ľang c·, nhԀp: Click vào nút 

CommandButton ĽԜ thoát kh i֛ chҼҺng tr ình 

FONT 
NhӸp Ô 3 chӸm bên PhӶi > Ch n֙ Font VNI -Helve-

Condense và Size 12 trong H p֥ ThoӴi  hi n֓ ra. 

 

 BӴn xác lԀp ( NhԀp vŁn bӶn và tùy ch֙n )  các thu֥ c tính cֳ a Label1 nhҼ BӶng Ľ« cho 
nhҼ tr°n. Sau khi x§c lԀp thu֥ c tính vào BӶng Properties-Nhanbon, Form sԐ hiԜn th֗  theo 

các giá tr֗ Ľ« nhԀp . Chú Ý: Khi ch֙ n Font VNI, bӴn nh֧  ch֙ n VNI Windows nԒu xài 

UNIKEY. Khi bӴn nhԀp vŁn bӶn vào trong Caption bӴn sԐ thӸy nó hiԜn th  ֗không Ľúng chֻ  

Vi t֓ có dӸu nhҼng trong Form sԐ hiԜn th  ֗Ľúng chֻ  Vi t֓.BӴn nên xác lԀp Font trҼc֧ khi 

nhԀp vŁn bӶn vào Caption.  

 

 

ñCĆCH Tξ HΙC HAY NHʟT LÀ DʛY NGʆΪI KHÁC CÙNG H ΙC . 
ÚT B N˃H VI T́ BÀI  VÌ CÁC EM NGÔ B ʝO CHĄU TʆʄNG LAI.ò 
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.  

 

 

 

 

 

 

 

 

 

 

 

 

NhԀn xét: Khi bӴn thiԒtkԒ 4 Label này bӴnthӸy Properties gi֝ ngnhau, ch֕  khác: Tên ï 

Caption.  

Cách xác lԀp Font mԊc Ľ֗nh cho Visual Basic: Trong tr Ҽ֩ ng h p֯ bӴn thҼ֩ ng xuyên sֹ  

d nֱg Font và Size ĽԜ thiԒt kԒ, bӴn nên ch n֙ Font và Size mԊc Ľ֗nh theo ý thích c aֳ bӴn 

bԄng cách : Vào Menu Tools > Ch֙ n Options > NhӸp Tab Edit Format > Ch n֙ Font và 

Size trong M cֱ Font và Size > OK. 

3.THI T́ K  ́TEXTBOX DĒNG ņ ̔THÔNG BÁO LΪI CHÀO  

 Ch֙ n Công c  ֱTextBox trong H֥ p ToolBox > Rê trên Form tӴo vùng ch֙ n > ThӶ chu֥ t ra 
thӸy hi n֓ chֻ  Text1 > Qua PhӶi vào Properties ï Text1, thֽ c hi n֓ nhԀp và tùy ch֙ n nhҼ 

sau :  

o Name: Thongbao 

o Alignment: 2-Center 

o BackColor: Màu dâu 

o Font: VNI -Helve-Condense, Size 16 

o Text: Xóa chֻ  Text, sau khi xóa sԐ thӸy tr n֝g trong vùng ch֙ n này.. 
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4.THI T́ K  ́3 COMMANDBUTTON, TRONG ņč: 1 COMMANDBUTTON 

DĒNG ņ ̔XEM THÔNG BÁO ï 1 COMMANDBUTTON DĒNG ņ ̔XÓA 

THÔNG TIN ï 1 COMMANDBUTTON DĒNG ņ ̔THOÁT KHΛI CHʆʄNG 

TRÌNH  

A.ThiԒt KԒ CommandButton t°n ñNutxemôô  

 Ch֙ n Công c  ֱCommmandButton trong H֥ p ToolBox > Rê trên Form tӴo vùng 

ch֙ n > ThӶ chu֥ t ra thӸy hi n֓ chֻ  Command1 > Qua PhӶi vào Properties ï 

Command1, thֽc hi n֓ nhԀp và tùy ch֙ n nhҼ sau :  

 

o Name: Nutxem 

o BackColor: Màu dâu nhӴt 

o Caption: Xem thông báo 

o Font: VNI -Helve-Condense, Size 20 

o Style: 1-Graphical. ( NԒu không xác lԀp thu c֥ tính này, nút 

CommandButton sԐ không có màu) 

 KԒt quӶ: 

 

 

 

 

 

B.ThiԒt KԒ CommandButton t°n ñNutxoaôô  

 Ch֙ n Công c  ֱCommmandButton trong H֥ p ToolBox > Rê trên Form tӴo vùng 
ch֙ n > ThӶ chu֥ t ra thӸy hi n֓ chֻ  Command1 > Qua PhӶi vào Properties ï 

Command1, thֽ c hi n֓ nhԀp và tùy ch֙ n nhҼ sau :  

 

o Name: Nutxoa 

o BackColor: Màu dâu nhӴt 

o Caption: Xóa thông báo 

o Font: VNI -Helve-Condense, Size 20 

o Style: 1-Graphical. ( NԒu không xác lԀp thu c֥ tính này, nút 

CommandButton sԐ không có màu) 

 KԒt quӶ: 
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C.ThiԒt KԒ CommandButton t°n ñNutxoaôô  

 Ch֙ n Công c  ֱCommmandButton trong H֥ p ToolBox > Rê trên Form tӴo vùng 
ch֙ n > ThӶ chu֥ t ra thӸy hi n֓ chֻ  Command1 > Qua PhӶi vào Properties ï 

Command1, thֽc hi n֓ nhԀp và tùy ch֙ n nhҼ sau :  

o Name: Nutthoat 

o BackColor: Màu dâu nhӴt 

o Caption: Thoát kh i֛ chҼҺng tr ình 

o Font: VNI -Brush, Size 24 

o Style: 1-Graphical. ( NԒu không xác lԀp thu c֥ tính này, nút 

CommandButton sԐ không có màu) 

 KԒt quӶ: BӴn Ľã thiԒt kԒ hoàn tӸt 1 Form g֟ m  4 Label, 1 TextBox và 3 
CommnadButton. 

 

 

 

 

 

  

 

 

 

 

 

 LҼu: Vào Menu File > NhӸp Save Project As > HT Save As hin֓ ra, ch֙ n Desktop 
> File Name ch֙n mԊc Ľ֗nh là: Project1 ï Save As Type ch֙n mԊc Ľ֗nh là: Project 

Files (*.vbp) > NhӸp nút Save. 
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 M  ֫File Ľ« lҼu: NhӸp Ľúp File Project1 tӴi Desktop > Hiên ra Cֹ a s֡  Project1 ( 
Design ), nhӸp dӸu + trҼc֧ Form1 > Hi֓ n ra File Baimot (Baimot.frm) > NhӸp Ľúp 

lên File này > Hi n֓ ra giao di֓n ĽԜ bӴn bԂt ĽӺu thiԒt kԒ tiԒp t cֱ. 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

I I .VI T́ CODE CδA CHʆʄNG TRČNH 

A.VI T́ CODE CHO NÚT COMMAMDBUTTON: NUTXEM  

1. BӴn có thԜ vào C aֹ S֡  viԒt Code bԄng 1 trong nhֻ ng cách sau Ľây: Click Ph֕a lên Form > 

Ch֙ n View Code hoԊc vào Menu View > Ch֙n Code hoԊc vào c aֹ s֡  Project > Ch֙n 

Baimot.frm > NhӸp Icon tên View Code. Khi viԒt Code nh֧  th n֝g nhӸt dùng Font VNI nԒu 

ngay tַ  ĽӺu Ľã dùng Font này. 
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2. Sau khi thֽ c hi n֓ 1 trong 3 cách trên, Cֹ a s֡  viԒt Code m֫  ra. BӴn cӺn ch n֙ ņiԚu KhiԜn ĽԜ 

viԒt Code và Click chu֥ t, trong bài này bӴn ch֙ n ņiԚu KhiԜn CommandButton có tên 

Nutxem. 

 

 

 

 

 

 

 

 

3. BӴn thӸy VB gán biԒn c֝  mԊc nhiên v i֧ ņiԚu KhiԜn Ľó trong H֥ p ComboBox  bên PhӶi , 

trong trҼn֩g h p֯ này là CLICK . BӴn có thԜ ch֙ n biԒn c  ֝khác trong ComboBox này. VB cho 

biԒt 2 Dòng L n֓h ĽӺu và Cu֝ i nhҼ sau: 

 

 

 

  

 

 

4. BӴn nhԀp Code gi֝ ng n i֥ dung này vào gi aֻ 2 Dòng: 

Thongbao.Text = òCHêO MNֶG BӳN ņԑN V I֦ VISUAL BASICò 

 

 

 

 

 

 

 GiӶi thích:  

 

 Nutxem_Click(): L à biԒn c  ֝Click vào nút có Name là Nutxem. Khi bӴn click 

vào nút này, hôp TextBox có tên Thongboa sԐ hi n֓ ra câu: ñCHÀO M NֶG 

BӳN ņԑN V I֦  VISUAL BASICò. 

 Thongbao: Là thu c֥ tính Name cֳ a TextBox, bӴn phӶi ghi Ľúng. 

 


